Коммутаторы серии Quidway являются функциональным решением для операторов связи любого уровня. 24 медных порта используются для подключения конечных пользователей, 2 uplink порта дают возможность подключения устройства к вышестоящим коммутаторам “уровня агрегации”. В случае большой нагрузки позволяют организовать единый канал.
Суммарная скорость всех портов коммутатора составляет около 8,8 Гб/c.
Размер таблицы мак-адресов — 8000. Этого значения хватает для решения любых сетевых задач. Количество поддерживаемых VLAN составляет 4096.
Коммутаторы данной серии обладают возможностью управления по протоколу SNMPv1/v2c/v3, SSHv2. Поддерживают IPV6, IGMPv1/v2c/v3 и авторизацию по протоколу EEE 802.1x.

Распространенные команды, используемые при работе с коммутатором

Оборудование Huawei построено на базе операционной системы VRP и имеет большое сходство с интерфейсом CLI Cisco IOS. В оборудовании существует 2 режима командного интерфейса:
user-view — непривилегированного режим
system-view – привилегированный режим

Команды для просмотра информации

display current-configuration — просмотр конфигурации коммутатора. Вывод команды может занимать много строк.

display current-configuration interface ethernet0/0/8 позволяет отобразить текущую конфигурацию для определенного интерфейса, например

SW1-Q2326> display current-configuration interface  Ethernet 0/0/8
#
interface Ethernet0/0/8
 loopback-detect enable
 loopback-detect action shutdown
 stp edged-port enable
 traffic-filter inbound acl 1 rule 10
 traffic-filter inbound acl 2 rule 20
 traffic-filter inbound acl 3 rule 30
 undo ntdp enable
 undo ndp enable
 undo lldp enable
 port-isolate enable group 10
#
return

display interface — просмотр состояния порта

Если в команде не был указан конкретный интерфейс, то команда отобразит информацию обо всех интерфейсах на коммутаторе.

Просмотр информации абонентского интерфейса

SW1-Q2326> display interface Ethernet0/0/2
Ethernet0/0/2 current state : UP
Line protocol current state : UP
Description:HUAWEI, Quidway Series, Ethernet0/0/2 Interface
Switch Port, PVID :   10, TPID : 8100(Hex), 
The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, 
Hardware address is 0025-9e0e-e3c8
Port Mode: COMMON COPPER
Speed :  100,  Loopback: NONE
Duplex: FULL,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 64200 bits/sec, 46 packets/sec
Last 300 seconds output rate 167936 bits/sec, 60 packets/sec
Input peak rate 6230872 bits/sec, Record time: 2015-05-22 12:09:21
Output peak rate 82646216 bits/sec, Record time: 2015-05-20 22:28:51
Input:  104198 packets, 36893522 bytes
Unicast        :    104192, Multicast          :        0
Broadcast      :         6, Jumbo              :        0
CRC            :         0, Giants             :        0
Jabbers        :         0, Fragments          :        0
Runts          :         0, DropEvents         :        0
Alignments     :         0, Symbols            :        0
Ignoreds       :         0, Frames             :        0
Discard        :         0, Total Error        :        0
Output:  2351712 packets, 1668837078 bytes
Unicast        :   2140589, Multicast          :   166992
Broadcast      :     44131, Jumbo              :        0
Collisions     :         0, Deferreds          :        0
Late Collisions:         0, ExcessiveCollisions:        0
Buffers Purged :         0  Discard        :            0, 
Total Error    :         0
    Input bandwidth utilization threshold : 100.00%
    Output bandwidth utilization threshold: 100.00%
    Input bandwidth utilization  : 0.06%
    Output bandwidth utilization : 0.17%

В домовых сетях для связи между коммутаторами используются гигабитные порты. Просмотр информации UPLINK интерфейса.

SW1-Q2326> display interface GigabitEthernet 0/0/1
GigabitEthernet0/0/1 current state : UP
Line protocol current state : UP
Description:HUAWEI, Quidway Series, GigabitEthernet0/0/1 Interface
Switch Port, PVID :    10, TPID : 8100(Hex), 
The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, 
Hardware address is 4cb1-6c6d-f0e2
Port Mode: COMBO AUTO
Current Work Mode: COPPER
Speed : 1000,  Loopback: NONE
Duplex: FULL,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 24997688 bits/sec, 2342 packets/sec
Last 300 seconds output rate 1229104 bits/sec, 579 packets/sec
Input peak rate 336254096 bits/sec, Record time: 2015-07-21 03:46:12
Output peak rate 222242920 bits/sec, Record time: 2015-09-18 02:36:47
Input:  10903526547 packets, 14024800132234 bytes
Unicast    :  3191030272, Multicast          :  7711769187
Broadcast  :      727088, Jumbo              :           0
CRC        :           0, Giants             :           0
Jabbers    :           0, Fragments          :           0
Runts      :           0, DropEvents         :           0
Alignments :           0, Symbols            :           0
Ignoreds   :           0, Frames             :           0
Discard    :           0, Total Error        :           0
Output:  2017739656 packets, 1111756329252 bytes
Unicast    :  2014859007, Multicast          :     1743883
Broadcast  :     1136766, Jumbo              :           0
Collisions :           0, Deferreds          :           0
Late Collisions:       0, ExcessiveCollisions:           0
Buffers Purged :       0
Discard    :           0, Total Error        :           0
    Input bandwidth utilization threshold : 100.00%
    Output bandwidth utilization threshold: 100.00%
    Input bandwidth utilization  : 2.50%
    Output bandwidth utilization : 0.12%

display mac-address — просмотр мак-адреса

SW1-Q2326>display mac-address
-------------------------------------------------------
MAC Address    VLAN/VSI     Learned-From        Type
-------------------------------------------------------
1caf-f762-b607 10/-        Eth0/0/2            dynamic
2c39-96a8-60f5 10/-        Eth0/0/24           dynamic
2c39-96a8-60f6 10/-        Eth0/0/24           dynamic
2c39-96d9-6d4e 10/-        GE0/0/2             dynamic
2c39-96d9-6d4f 10/-        GE0/0/2             dynamic
348a-ae19-aa1b 10/-        GE0/0/2             dynamic
348a-ae19-aa1c 10/-        GE0/0/2             dynamic
e894-f6b7-a00d 10/-        Eth0/0/3            dynamic
0025-9ed4-64ca 20/-        GE0/0/1             dynamic
286e-d455-d7b0 20/-        GE0/0/2             dynamic
-------------------------------------------------------
Total items displayed = 10

При указании номера интерфейса команда покажет информацию о мак-адресах на конкретно заданном интерфейсе, например:

	
SW1-Q2326> display mac-address dynamic Ethernet0/0/2
------------------------------------------------------------------
MAC Address    VLAN/VSI            Learned-From           Type
------------------------------------------------------------------
1caf-f762-b607 10/-                   Eth0/0/2            dynamic

------------------------------------------------------------------
Total items displayed = 1

Отбор данных по заданному признаку осуществляется с помощью include. Например, нам необходимо найти порт на коммутаторе, зная только мак-адрес оборудования. В этом случае нам поможет следующая команда:

SW1-Q2326> display mac-address dynamic | include 1caf-f762-b607
MAC address table of slot 0:
------------------------------------------------------------------
MAC Address    VLAN/   PEVLAN CEVLAN   Port      Type  LSP/LSR-ID
               VSI/SI                                              
------------------------------------------------------------------
1caf-f762-b607  10        -    -     Eth0/0/2  dynamic      -

------------------------------------------------------------------
Total matching items on slot 0 displayed = 10

Результат отработки команды показывает, что нужный нам мак-адрес 1caf-f762-b607 находится на 2 порту коммутатора.

display interface description — просмотр описания портов коммутатора.

SW1-Q2326> display interface description
Interface       Description
Ethernet0/0/1   HUAWEI, Quidway Series, Ethernet0/0/1 Interface
Ethernet0/0/2   HUAWEI, Quidway Series, Ethernet0/0/2 Interface
Ethernet0/0/3   HUAWEI, Quidway Series, Ethernet0/0/3 Interface
Ethernet0/0/4   HUAWEI, Quidway Series, Ethernet0/0/4 Interface
Ethernet0/0/5   HUAWEI, Quidway Series, Ethernet0/0/5 Interface
Ethernet0/0/6   HUAWEI, Quidway Series, Ethernet0/0/6 Interface
Ethernet0/0/7   HUAWEI, Quidway Series, Ethernet0/0/7 Interface
Ethernet0/0/8   HUAWEI, Quidway Series, Ethernet0/0/8 Interface
GigabitEthernet0/0/1  HUAWEI, Quidway Series, GigabitEthernet0/0/1                       
NULL0           HUAWEI, Quidway Series, NULL0 Interface
Vlanif10        HUAWEI, Quidway Series, Vlanif998 Interface

Описание (description) можно изменить на свое. Это очень важно и позволяет прописать необходимую служебную информацию, например

SW1-Q2326>system
Enter system view, return user view with Ctrl+Z.
[SW1-Q2326] interface Ethernet0/0/3
[SW1-Q2326] description client_bank_ug

display interface brief — просмотр информации о интерфейсах в виде сводной таблицы

SW1-Q2326> display interface brief
PHY: Physical
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
(b): BFD down
(e): ETHOAM down
(d): Dampening Suppressed
InUti/OutUti: input utility/output utility
Interface         PHY   Protocol InUti OutUti   inErrors  outErrors
Ethernet0/0/1     up    up       0.01%  1.82%          0      0
Ethernet0/0/2     down  down        0%     0%       7535      0
Ethernet0/0/3     up    up       0.01%  0.01%       1318      0
Ethernet0/0/4     up    up       0.03%  4.30%        102      0
Ethernet0/0/5     up    up       0.09%  4.22%          0      0
Ethernet0/0/6     up    up       0.01%  1.94%          0      0
Ethernet0/0/7     down  down        0%     0%          0      0
Ethernet0/0/8     up    up       0.01%  0.01%      25738      0
Ethernet0/0/9     up    up       0.10%  4.13%          0      0
Ethernet0/0/10    up    up       0.01%  0.01%       1333      0
Ethernet0/0/11    up    up       0.35%  3.98%          0      0
Ethernet0/0/12    up    up       0.01%  0.01%          0      0
Ethernet0/0/13    up    up       0.01%  1.92%          0      0
Ethernet0/0/14    up    up       0.01%  0.01%          0      0
Ethernet0/0/15    up    up       0.01%  0.01%          0      0
Ethernet0/0/16    down  down        0%     0%          5      0
Ethernet0/0/17    up    up       0.01%  0.01%          0      0
Ethernet0/0/18    up    up       0.01%  0.03%          0      0
Ethernet0/0/19    up    up       0.06%  2.61%          0      0
Ethernet0/0/20    down  down        0%     0%          0      0
Ethernet0/0/21    up    up       0.01%  5.73%          0      0
Ethernet0/0/22    up    up       0.04%  2.38%          0      0
Ethernet0/0/23    up    up       0.01%  1.86%          0      0
Ethernet0/0/24    down  down        0%     0%          0      0
GigabitEthernet0/0/1  up  up     3.63%  0.08%          0      0
GigabitEthernet0/0/2  up  up     0.08%  1.30%          6      0
NULL0             up    up(s)       0%     0%          0      0
Vlanif10          up    up          --     --          0      0

display ip interface brief — просмотр информации o назначенных IP-адресах на интерфейсах в виде сводной таблицы.

SW1-Q2326> display ip interface brief
*down: administratively down
(l): loopback
(s): spoofing

The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 0
The number of interface that is UP in Protocol is 2
The number of interface that is DOWN in Protocol is 0

Interface           IP Address/Mask   Physical   Protocol
NULL0               unassigned           up       up(s)
Vlanif20            10.15.75.1/24        up       up

display arp dynamic — просмотр ARP таблицы. ARP таблица показывает соответствие мак-адреса с IP-адресом.

SW1-Q2326> display arp dynamic
IP ADDRESS      MAC ADDRESS  EXPIRE(M) TYPE INTERFACE  VPN-INSTANCE
                                       VLAN
------------------------------------------------------------------
10.0.0.1    7054-f59d-2040         I -  Vlanif10
10.0.0.2    7054-f5a3-0629  18     D-0  GE0/0/1
                                       100
10.0.0.3    001f-ce8e-2681  19     D-0  GE0/0/1
                                       100
10.0.0.4    4862-760c-ed0b  18     D-0  GE0/0/1
                                       100
10.0.0.5    5439-df24-4b2e  12     D-0  GE0/0/1
                                       100
10.0.0.6    4862-760c-ec20  17     D-0  GE0/0/1
                                       100
10.0.0.7    04f9-38d4-e968  10     D-0  GE0/0/1
                                       100
------------------------------------------------------------------
Total:7         Dynamic:6       Static:0    Interface:1

Если необходимо найти ARP запись, зная мак-адрес устройства, то можно использовать фильтр как показано ниже:

SW1-Q2326> display arp dynamic | include 5439-df24-4b2e
IP ADDRESS      MAC ADDRESS  EXPIRE(M) TYPE INTERFACE  VPN-INSTANCE
                                       VLAN
------------------------------------------------------------------
10.0.0.5    5439-df24-4b2e  12     D-0  GE0/0/1         100
------------------------------------------------------------------
Total:100         Dynamic:6       Static:0    Interface:1

display vlan — просмотр информации о созданных виртуальных каналах VLAN

SW1-Q2326> display vlan
* : management-vlan
---------------------
The total number of vlans is : 3
VLAN ID Type Status   MAC   Learning Broadcast/Multicast/Unicast 
-----------------------------------------------------------------
10  common   enable  enable forward   forward   forward default
20  common   enable  enable forward   forward   forward default
30  common   enable  enable forward   forward   forward default

display interface-statictics — просмотр статистики интерфейса.

SW1-Q2326> display interface-statistics Ethernet 0/0/4
Display statistics of the interface at the interval of 10 seconds 
for up to 5 times. Press Ctrl + C to stop.
  0 seconds left/
Times 1
Interface : Ethernet0/0/4
-----------------------------------------------------------
Input rate   :        6076 bits/sec,          8 packets/sec
Output rate  :      134038 bits/sec,         21 packets/sec
Input        :    11157207400 bytes,       37188825 packets
Output       :    99204215929 bytes,      242511489 packets
Input error  :             4 packets
Output error :             0 packets
Input bandwidth utilization  : 0.01%
Output bandwidth utilization : 0.07%

Позволяет проверить загрузку канала и выявить рост ошибок

Команды для управления интерфейсами

shutdown и undo shutdown — включение/отключение административной блокировки интерфейса.

Команды работают в режиме system

Включение административной блокировки

SW1-Q2326> system
Enter system view, return user view with Ctrl+Z.
[SW1-Q2326] interface Ethernet0/0/19
[SW1-Q2326-Ethernet0/0/19] shutdown

После данной команды информация о состоянии интерфейса будет выглядеть следующим образом

SW1-Q2326> display interface Ethernet0/0/2
Ethernet0/0/8 current state : Administratively DOWN
Line protocol current state : DOWN
Description:HUAWEI, Quidway Series, Ethernet0/0/2 Interface
Switch Port, PVID:10, TPID:8100(Hex),
The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, 
Hardware address is 4cb1-6c6d-f0e2
Port Mode: COMMON COPPER
Speed :   10,  Loopback: NONE
Duplex: HALF,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 0 bits/sec, 0 packets/sec
Last 300 seconds output rate 0 bits/sec, 0 packets/sec
Input peak rate 0 bits/sec, Record time: -
Output peak rate 0 bits/sec, Record time: -
Input:  0 packets, 0 bytes

undo shutdown — снятие административной блокировки порта.

	
SW1-Q2326> system
Enter system view, return user view with Ctrl+Z.
[SW1-Q2326] interface Ethernet0/0/19
[SW1-Q2326-Ethernet0/0/19] undo shutdown

virtual-cable-test — проверка длины кабеля от порта коммутатора до абонентского устройства.

SW1-Q2326> system
Enter system view, return user view with Ctrl+Z.
[SW1-Q2326] interface Ethernet0/0/3
[SW1-Q2326-Ethernet0/0/3] virtual-cable-test
Warning: The command will stop service for a while, continue [Y/N]?y
Pair A length: 50meter(s)
Pair B length: 50meter(s)
Pair A state: Ok
Pair B state: Ok

reset counters Ethernet0/0/3 — позволяет сбросить счетчики статистики на выбранном интерфейсе, например

SW1-Q2326> reset counters interface Ethernet 0/0/1 

display log — выводит лог работы порта. Данная информация позволит собрать статистику работы порта и определить источник проблемы.

Для просмотра логов конкретного порта необходимо набрать следующую команду:

SW1-Q2326> display log | include 0/0/18
Logging buffer configuration and contents : enabled
Allowed max buffer size : 1024
Actual buffer size : 512
Channel number : 4 , Channel name : logbuffer
Dropped messages : 0
Overwritten messages : 0
Current messages : 405

Jan 26 2016 00:16:26+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[10]:Interface Ethernet0/0/18 
has turned into DOWN state.
Jan 25 2016 10:06:53+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[23]:Interface Ethernet0/0/18 
has turned into UP state.
Jan 25 2016 10:06:47+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[24]:Interface Ethernet0/0/18 
has turned into DOWN state.
Jan 25 2016 10:06:42+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[25]:Interface Ethernet0/0/18 
has turned into UP state.
Jan 25 2016 07:59:31+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[36]:Interface Ethernet0/0/18 
has turned into DOWN state.
Jan 25 2016 07:42:39+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[37]:Interface Ethernet0/0/18 
has turned into UP state.
Jan 25 2016 07:42:33+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[38]:Interface Ethernet0/0/18 
has turned into DOWN state.
Jan 25 2016 07:42:28+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[39]:Interface Ethernet0/0/18 
has turned into UP state.
Jan 25 2016 02:50:24+03:00 SW1-Q2326 
%%01IFNET/4/IF_STATE(l)[40]:Interface Ethernet0/0/18 
has turned into DOWN state.

display patch-information — выводит информацию о установленных патчах

SW1-Q2326> display patch-information
Patch Package Name :flash:/s2300_v100r006sph012.pat
Patch Package Version:V100R006SPH012
The state of the patch state file is: Running
The current state is: Running

***************************************************
* The hot patch information, as follows: *
***************************************************

Slot Type State Count
---------------------------------------------------
0 C Running 28

display current-configuration — просмотр конфигурации порта

SW1-Q2326> display current-configuration interface Ethernet 0/0/1
#
interface Ethernet0/0/1
port link-type access
loopback-detect enable
loopback-detect action shutdown
stp edged-port enable
traffic-filter inbound acl 1001 rule 10
traffic-filter inbound acl 2002 rule 20
traffic-filter inbound acl 3003 rule 30
undo ntdp enable
undo ndp enable
undo lldp enable
port-isolate enable group 1
#
return
 

Команды для настройки VLAN

Для создания VLAN используется команда vlan {vlan-id}
Например:

huawei> system-view
[huawei] vlan 150
[huawei-vlan150] quit

Для удаления VLAN — undo vlan {vlan-id}

Настройка VLAN для access порта

В режиме конфигурирования интерфейса задаем режим работы порта — access.

[huawei-GigabitEthernet0/0/1] port link-type access

После указываем номер VLAN (по умолчанию на порту используется VLAN-ID 1)

[huawei-GigabitEthernet0/0/1] port default vlan {vlan-id}

Например:

huawei> system-view
[huawei] interface GigabitEthernet 0/0/1
[huawei-GigabitEthernet0/0/1] port link-type access
[huawei-GigabitEthernet0/0/1] port default vlan 150
[huawei-GigabitEthernet0/0/1] quit

Настройка VLAN для trunk порта

В режиме конфигурирования интерфейса задем тип — trunk.

[huawei-GigabitEthernet0/0/1] port link-type trunk

Добавляем номера VLAN в trunk через пробел или диапазон.

[huawei-GigabitEthernet0/0/1] port trunk allow-pass vlan {vlan-id1 vlan-id2 … vlan-idn}

Например:

huawei> system-view
[huawei] interface GigabitEthernet 0/0/1
[huawei-GigabitEthernet0/0/1] port link-type trunk
[huawei-GigabitEthernet0/0/1] port trunk allow-pass vlan 150 200 to 220
[huawei-GigabitEthernet0/0/1] port trunk pvid vlan 150
[huawei-GigabitEthernet0/0/1] quit

Настройка VLAN для hybrid порта

В режиме конфигурирования интерфейса задем тип — hybrid.

[huawei-GigabitEthernet0/0/1] port link-type hybrid

Добавляем номера тегированных VLAN.

[huawei-GigabitEthernet0/0/1] port hybrid tagged vlan {vlan-id1 vlan-id2 … vlan-idn}

Добавляем номера нетегированных VLAN.

[huawei-GigabitEthernet0/0/1] port hybrid untagged vlan {vlan-id1 vlan-id2 … vlan-idn}

Добавляем PVID для нетегированной VLAN, по умолчанию используется PVID = 1

[huawei-GigabitEthernet0/0/1] port hybrid pvid vlan {vlan-id}

Например:


huawei> system-view
[huawei] interface GigabitEthernet 0/0/1
[huawei-GigabitEthernet0/0/1] port link-type hubrid
[huawei-GigabitEthernet0/0/1] port hybrid tagged vlan 150 200 to 210
[huawei-GigabitEthernet0/0/1] port hybrid untagged vlan 10 20
[huawei-GigabitEthernet0/0/1] port hybrid pvid vlan 10 
[huawei-GigabitEthernet0/0/1] quit